View Issue Details

IDProjectCategoryView StatusLast Update
0004177Multi Theft Auto : San AndreasServerpublic2009-05-25 00:36
ReporterPaul_Cortez Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Fixed in Version1.0 
Summary0004177: isPedDead always returns false when used on peds
Description

Summary pretty much says it all. Doesn't matter if the ped is dead or alive. Worked fine for players last time I tried.

Either it should work for peds properly, or it should be deleted and replaced with isPlayerDead again. Kind of pointless to have a ped function which doesn't even work on peds.

TagsNo tags attached.

Activities

lucasc190

2009-04-14 09:33

reporter   ~~0008809

This is probably because the ped was not killed server-side and the server didn't know that the ped was dead. Try triggering a server-side event from the client syncer when "onClientPedWasted" is triggered that calls "killPed" server-side. "isPedDead" worked fine with peds on my server after I did what I suggested above.

Cazomino05

2009-05-25 00:33

reporter   ~~0009372

Can't reproduce in most recent nightly so I am closing this, I guess I fixed this in r849

Issue History

Date Modified Username Field Change