View Issue Details

IDProjectCategoryView StatusLast Update
0004175Multi Theft Auto : San AndreasClientpublic2014-06-27 19:23
ReporterrobholAssigned ToCazomino05 
PriorityhighSeveritymajorReproducibilitysometimes
Status resolvedResolutionfixed 
Product Version 
Target Version1.4Fixed in Version1.4 
Summary0004175: Vehicles are randomly "moved"/respawned
Description

Placed vehicles are sometimes somehow moved away from the place from which they were intended to spawn, and placed somewhere else. This "somewhere else" is commonly in the middle of a road, making this quite annoying.

Apparently this does not happen exclusively with two or more players as was believed earlier. It can happen even with one player on the server.

Additional Information

It appears that the vehicles are somehow dropped through the ground and into "The Void," which causes them to respawn at random above-ground locations.

This seems to occur most often at certain points. I've discovered a couple in SF, like Wang Cars (outside) where they appear in the road directly to the west of the building, or the western edge of the Ocean Flats residential area, where they're also moved into the road.

TagsNo tags attached.

Relationships

related to 0006492 resolvedCazomino05 Vehicles fall through the water without drowning and teleport to the nearest part of San Andreas 
child of 0007809 resolvedCazomino05 [p] Vehicles fall through the map and lose their syncer 

Activities

Arc

2009-04-13 12:33

administrator   ~~0008798

Precise steps to reproduce?

robhol

2009-04-13 12:42

reporter   ~~0008800

1) Place cars
2a) Player 1 joins the server
2b) Player 2 joins the server
2c) Any other players join the server
3) Wait until it happens, I guess... ;)

Entering and exiting the area several times might help "speeding up the process" if it is indeed a streaming issue. Apart from that I'm afraid I can't really help more.

Cazomino05

2009-05-25 00:39

reporter   ~~0009373

I went on robhol's server earlier this week and witnessed this, It seems to be that the vehicles are being streamed in before the collisions for the floor are loaded, Therefore the vehicle falls through the floor and GTA re-spawns it at the nearest road.

jhxp

2009-12-13 11:30

administrator   ~~0010862

Re-test on 1.0.3

robhol

2009-12-26 13:17

reporter   ~~0010929

Still is happening.

x86

2010-02-05 23:58

administrator   ~~0011043

Found something in CMultiplayerSA.cpp
line 864:

// EXPERIMENTAL - disable unloading of cols

// memset( (void*)0x4C4EDA, 0x90, 10 );

Mr.Hankey

2010-02-06 00:12

reporter   ~~0011044

I'm not quite sure if this is the same issue but I noticed that sometimes respanwed vehicles don't have their velocity reset and get a small impulse when you get close.

MX_Master

2011-02-21 18:49

viewer   ~~0012976

confirmed, just spawned vehicle sometimes appears on the road not far from spawn point. I was alone on my local server and saw this respawn situation.

vehicle was not falling under the ground, it just appears immediately on the road, but half second before it was exactly on spawn point. By the way, I'm using custom respawn timers and empty vehicle can respawn while some players was near it.

XX3

2011-02-22 14:45

viewer   ~~0012985

This also happens on custom created maps. Example, when you go far enough, I can see the objects gone and the vehicles above it fell into the water. I think it's probably the same thing as this one, but into the void instead.

Cazomino05

2014-06-27 19:21

reporter   ~~0021148

fixed in https://code.google.com/p/mtasa-blue/source/detail?r=6612

Issue History

Date Modified Username Field Change