View Issue Details

IDProjectCategoryView StatusLast Update
0004166Multi Theft Auto : San AndreasVehiclespublic2017-07-15 16:52
Reporter[PS]DazzaJay[AU]Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformPCOSWindows XP X64 EditionOS VersionCorporate
Product Version1.5.4 
Target Version1.5.5Fixed in Version1.5.5 
Summary0004166: Engine Sounds of other Helicopters and planes missing unless you get in a Helicopter or plane.
Description

Engine Sounds of another persons Helicopter cannot be heard unles you get into that helicopter, or get into another helicopter.

EDIT
Also works with planes

Steps To Reproduce

run me.position = Vector3(-5, -25, 4)
run veh = Vehicle(487, 0, -30, 4)
run ped = Ped(16, 0, -40, 4)
run ped:warpIntoVehicle(veh)

TagsNo tags attached.

Users sponsoring this issue
Sponsors List Total Sponsorship = EUR 10

2012-05-25 22:48: arranTuna (EUR 10)
Users sponsoring this issue (Total Sponsorship = EUR 10)

Relationships

related to 0004723 resolvedryden Multi Theft Auto : San Andreas Players cant hear the player play the ice cream song of the mrwhoopee vehicle 
has duplicate 0008511 closed New issues Aircraft SFX 

Activities

[PS]DazzaJay[AU]

2009-04-09 10:45

reporter   ~~0008752

Heres a video.

I filmed this by loading the game, and saw Spinkstar in a Hunter, with no sound, Filmed it, got in a Hunter i spawned, and then sound for both worked.

http://files.potholestudios.com/dazzajay/mtaissues/HeliSoundBug.zip

Audio: Windows Media Audio 44100Hz stereo 64Kbps [Raw Audio 0]
Video: Windows Media Video 8 352x288 30.00fps 636Kbps [Raw Video 1]

Bento

2009-04-22 11:22

viewer   ~~0008881

This still occurs in r682, you have to get in a helicopter before the sounds will work. Once you have gotten in, you may get out and they will work fine until you close and reload MTA.

subenji99

2009-04-22 11:24

viewer   ~~0008882

We recreated it by having a player in-game (editor, test mode) flying a helicopter, the other player joins and spawns near the first player so the helicopter is streamed in on spawn.

scarface1994

2009-05-24 12:53

viewer   ~~0009362

Happens with air crafts too.

Flobu

2010-06-02 22:23

updater   ~~0011559

i think this can be fixed like #4723

ryden

2011-11-29 05:19

manager   ~~0015296

I would love to take a look at this one.

FunGt

2012-07-27 17:50

viewer   ~~0017164

This small bug still exists.

LeetWoovie

2012-07-27 17:51

viewer   ~~0017165

Yes, that's why it says ACKNOWLEDGED instead of FIXED.

einheit-101

2017-04-25 17:40

reporter   ~~0025847

I find it kinda funny that this ancient bug still exists. No one has an idea how to fix it yet?
A fix would save me from writing a custom sound script for Helicopters on my server, that would be amazing.

arranTuna

2017-04-26 19:09

manager   ~~0025848

@einheit-101 I guess they have an idea how to fix it because I remember many years ago Gamesnert who was actively developing at the time said that he was going to see what memory address it is that needs changing which you'd do by entering a helicopter and see what addresses changed then set that new memory address state without having to enter the helictoper, there is a list of memory hacks like this in 1 of the main MTA source files. I guess he either never got round to that, or it's more complex than that.

lopezloo

2017-05-05 19:25

developer   ~~0025901

PR: https://github.com/multitheftauto/mtasa-blue/pull/128

lopezloo

2017-07-04 15:28

developer   ~~0026055

Fixed: GitHub, buildinfo

StifflersMom

2017-07-09 20:21

updater   ~~0026059

Not fully fixed:
If you enter a car near a helicopter, the engine sound of the helicopter suddenly stops until you stream oou and in again.

StifflersMom

2017-07-09 21:11

updater   ~~0026060

Because there are more issues with the helicopter sounds, I decided to add a video:
https://www.youtube.com/watch?v=XurpNEgDZd8

The engine sound of the car changes to a monotone one gear sound, if a helicopter streams in.

lopezloo

2017-07-15 16:52

developer   ~~0026063

Fixed: GitHub, buildinfo

Should be fine now. Now by default aircraft uses same sounds as AI controlled aircraft in single player. However if you enter it (even as passenger), proper (unique) sounds are loaded.

Issue History

Date Modified Username Field Change