View Issue Details

IDProjectCategoryView StatusLast Update
0004157Multi Theft Auto : San AndreasClientpublic2018-09-06 07:17
Reporter[PS]DazzaJay[AU]Assigned ToCazomino05 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformPCOSWindows XP x64OS VersionCorporate
Product Version 
Target VersionFixed in Version1.0 
Summary0004157: Getting into Skimmer stops Jump from working if you fall into water instead of getting in.
Description

ok, If i have a Skimmer near the end of a Pier, and press F to enter it, my character will walk towards it and fall into water, when this happens, i find that F doess nothing anymore when trying to get into the same skimmer, and also that Jump no longer works in water, so i cannot climb back up onto the pier.

Steps To Reproduce

Place a skimmer near the end of a pier, and stand on the pier, press F to get in, and have your character auto-fall into the water. F will no longer do anything and neither wil jump.

TagsNo tags attached.

Relationships

related to 0004246 closed Vehicle entry bug in skimmer/seasparrow/leviathon etc 

Activities

[PS]DazzaJay[AU]

2009-04-07 01:26

reporter   ~~0008735

OK, i have made a video, because i am useless at explaining stuff in text. problem is its 2.6MB, so i cant upload it here.

Everything in the video is recreateable 100% of the time.

so, here's a link:
http://files.potholestudios.com/dazzajay/mtaissues/SkimmerEnterBug.zip

Audio: Windows Media Audio 44100Hz stereo 64Kbps [Raw Audio 0]
Video: Windows Media Video 8 352x288 30.00fps 636Kbps [Raw Video 1]

[PS]DazzaJay[AU]

2009-04-09 11:31

reporter   ~~0008754

Heres an idea, a Quick fix script, on start enter, if vehicle = skimmer, then warp player into vehicle.

wouldnt be as good as being able to use the door properly tho.

[PS]DazzaJay[AU]

2009-04-10 07:49

reporter   ~~0008763

ok, here is an LUA file that runs as a resource that does FIX the bug. HOWEVER, it will completley ignore if the vehicle is locked.

function skimmerFix ( player, seat, jacked )
if ( getVehicleModel ( source ) == 460 ) then
warpPedIntoVehicle ( player, source )
end
end
addEventHandler ( "onVehicleStartEnter", getRootElement(), skimmerFix )

Mr.Hankey

2009-04-10 11:45

reporter   ~~0008764

Last edited: 2009-04-10 13:08

iirc that's exactly what mta already does or have you ever seen a player entering the skimmer with an animation?

[PS]DazzaJay[AU]

2009-04-10 16:42

reporter   ~~0008765

Last edited: 2009-04-10 16:44

Watch the video, he CLEARLY tries to enter WITH ANIMATION.

and if its posisiotned absolutley perfectly, he will do the full animation, (walk to plane, jumps on pontoon, and opens door and gets in) instead of glitching out.

The video shows the glitch out, that happens when you Press F, the character runs to plane, falls in water, (because skimmer was not positioned absolutley perfectly, then Jump and Enter vehicle buttons no longer work.

[PS]DazzaJay[AU]

2009-04-18 23:47

reporter   ~~0008853

Last edited: 2009-04-18 23:48

Bug is partially fixed. Still occours if you try to enter as a Passenger. (r656)

Cazomino05

2009-04-19 00:01

reporter   ~~0008854

can you check for me if its outputting Failed to enter/exit vehicle - id: 5? I have tested this and can't reproduce other than that

ID 5 means the skimmer is too far away than the cut off distance

[PS]DazzaJay[AU]

2009-04-20 07:47

reporter   ~~0008865

Last edited: 2009-04-20 08:07

i know why you cant reproduce it.
(completley forgot to check console output tho)

A person needs to be in the Driver seat of the skimmer, and then have a potential passger press G to enter, and nothing happens, he cant jump, etc.

(link to vid comming soon)

:::EDIT:::
Ok, heres the vid, which even shows the point where i realise why you cant reproduce it. you will here me go "Ah! thats why he cant reproduce it"

http://files.potholestudios.com/dazzajay/Skimmer2Pbug.zip

Cazomino05

2009-04-20 09:00

reporter   ~~0008867

Last edited: 2009-04-21 01:37

Ok great, I will look at it when I get home :)
Edit: I have looked at it and after loads of time getting my old computer working, it should be fixed now. I also fixed another bug where (I think) you could not get into the skimmer which is on land and you in water

Issue History

Date Modified Username Field Change