View Issue Details

IDProjectCategoryView StatusLast Update
0004132Multi Theft Auto : San AndreasServerpublic2009-05-28 19:21
ReporterjeshaAssigned ToArc 
PrioritynormalSeveritycrashReproducibilitysometimes
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version1.0 
Summary0004132: Server crash after someone quits.
Description

If someone quits, the gameplay freezes, and server crashes.

TagsNo tags attached.

Activities

Arc

2009-03-27 21:39

administrator   ~~0008662

Last edited: 2009-03-27 21:39

Please elaborate on this, because the server does in fact not crash on player quit with standard resources started. What gamemode are you running when this happens? If it's a custom gamemode, can you upload it, or (even better) narrow down the code that causes the crash and post it here?

jesha

2009-03-27 21:41

viewer   ~~0008663

I'm running Race.

Arc

2009-03-27 21:55

administrator   ~~0008664

And that is the updated race gamemode for the nightlies right? (from resource svn)

The DP2 version of the gamemode does not work in the nightlies. And if you are using MTA DP2, you should be aware that this bug tracker is only for bugs and crashes in the MTA 1.0 nightly builds.

[CW]ExtremeR

2009-03-27 21:59

viewer   ~~0008665

<resource src="helpmanager" startup="1" protected="0"/>
<resource src="joinquit" startup="1" protected="0"/>
<resource src="mapcycler" startup="1" protected="0"/>
<resource src="mapmanager" startup="1" protected="0"/>
<resource src="parachute" startup="1" protected="0"/>
<resource src="resourcebrowser" startup="1" protected="1" default="true"/>
<resource src="resourcemanager" startup="1" protected="1"/>
<resource src="scoreboard" startup="1" protected="0"/>
<resource src="spawnmanager" startup="1" protected="0"/>
<resource src="votemanager" startup="1" protected="0"/>
<resource src="webadmin" startup="1" protected="0"/>
<resource src="race" startup="1" protected="0"/>

All the resources are up-to-date from SVN. Server crashes randomly - mostly on player quits, less on joins. I've noticed that server crashes more when players are using different builds but it DOES crash with the same build too.

Arc

2009-03-27 22:08

administrator   ~~0008666

Are you positive that the crash is caused by race? You should try running the minimum amount of resources and see which exact one causes it. Also, got any modules loaded?

[CW]ExtremeR

2009-03-27 22:14

viewer   ~~0008667

Well, i haven't got any server crashes while using freeroam so kinda yes but i'm not really sure about that.
There's no modules loaded.

We'll test.

lil_Toady

2009-03-27 22:16

administrator   ~~0008668

Got any crash dumps? If so upload them, tell your server revision and path.

scarface1994

2009-03-28 07:51

viewer   ~~0008676

I've never got this and haven't been able to reproduce this at all.

Paul_Cortez

2009-03-28 11:11

reporter   ~~0008678

I left my server on last night and I think I got this crash. When I came back, I saw my server with a window "Close application" and "Debug" on it. And this was the last thing the server reported:

"[02:35:45] QUIT: [Doesn't matter who] left the game [Quit]"

That's where the log ended, seems like it crashed right after. Or well, stopped responding.

But when I looked up, many others quit without the server crashing. So it seems like it's rare to me. What might explain scarface didn't get it yet.

scarface1994

2009-04-09 12:06

viewer   ~~0008756

Still unable to reproduce with loads of players joining and quitting.
Have tried on other servers too but nothing.

SkyBon

2009-04-09 20:51

viewer   ~~0008759

Go to MTA San Andreas\MTA\dumps and attach the dump, related to your crashes, to your next comment, ok?

Dragon

2009-04-27 22:52

reporter   ~~0008956

Last edited: 2009-04-27 22:58

I've had this problem about 3 times now
crash dumps
http://www.files.to/get/646975/mi18bq9obp

kwksnd

2009-04-27 23:06

reporter   ~~0008957

i get this crash quite often on player quits

im beigining to think its related to resources starting or stopping
cause i get it on refreshing of resources after editing as well
the deletion of markers or timers seem to cause it more often than anything.(some scripts that have quick timers controlling the creation and deletion of markers cause instant server crash 100% of the time on my server)

guessing but i think this is all related

Talidan

2009-04-28 03:04

administrator   ~~0008958

Dragon, that link doesnt seem tow ork here. Also, it is important that you state which nightly you used to produce the crash dumps.

scarface1994

2009-05-03 19:43

viewer   ~~0009014

Last edited: 2009-05-03 19:46

Here's my dump http://download62.mediafire.com/cwlywl1onmzg/zcmdnzg2fal/server_05032009_1930.dmp
Nightly: R711

Arc

2009-05-03 21:44

administrator   ~~0009017

Last edited: 2009-05-03 21:45

This crash was caused by a serverside camera not having a target. I added a null check, post in here whether or not the crash still occurs in the next nightly (723+).

Arc

2009-05-10 22:59

administrator   ~~0009172

Didn't hear anything back, assuming it's fixed.

Issue History

Date Modified Username Field Change