View Issue Details

IDProjectCategoryView StatusLast Update
0004122Multi Theft Auto : San AndreasGeneralpublic2009-08-23 02:01
ReporterTalidanAssigned ToJax 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target Version1.0Fixed in Version1.0 
Summary0004122: Add support for generic element attachment
Description

There should be support for attachment of elements that arent standard physical entities.

At this time, attachment is supported by objects,vehicles,peds,markers,blips and radar areas (and partially pickups).

With the increasing amount of MTA elements, it is often desirable to attach such elements as well. These include colshapes, 3D sounds, water etc.

This can be achieved by manually calculating offset positions and forcing the positions manually for these special elements.

TagsNo tags attached.

Relationships

has duplicate 0004030 closed New issues Can't attach Sound as element to other elements. 
has duplicate 0004109 closed New issues requesting the ability to attach colshapes to other elements 

Activities

Arc

2009-03-28 00:59

administrator   ~~0008672

Last edited: 2009-03-28 00:59

Attaching water to stuff is problematic. Each corner of a water area must be on an even integer X and Y coordinate. Also the sides of a water quadrant are always axis aligned, no matter how you position the corners (i.e. can't rotate quadratic water).

Talidan

2009-03-28 01:05

administrator   ~~0008673

Just to emphasize the situation with pickups:

1) Elements can be attached fine to pickups
2) Pickups cannot be attached to other elements. This is clearly because pickups use colshapes internally - and colshapes cannot be attached. This has meant pickup->element attachment is blocked.

Jax

2009-08-04 18:00

administrator   ~~0010124

If theres any bugs or elements that arent properly supported, list them here.

Issue History

Date Modified Username Field Change