View Issue Details

IDProjectCategoryView StatusLast Update
0004100Multi Theft Auto : San AndreasClientpublic2009-05-27 22:54
ReporterKaltsuAssigned Toryden 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version1.0 
Summary0004100: Sniper not causing damage after certain distance
Description

The sniper rifle stops causing damage to players and objects after a certain distance. I can still see players getting hit in my screen beyond this distance but it doesn't show up in the player's screen.

The players stop taking damage as soon as their nametag disappears (due to long distance) in my sniper scope. Any other objects (e.g. vehicles) stop taking damage after the same distance aswell.

This same bug also also affects the country rifle. For other weapons such as the M4, the range is shorter (nametag doesn't appear until closer distance).

Additional Information

I tested the sniper range in the latest MTA:SA nightly build (r442) and SA:MP 0.2X Update 1 and compared the results.

The sniper range in SA:MP seems to be significantly longer than in MTA:SA. Please see the attached screenshots to compare the range yourself.

According to these results, I think this bug is not a matter of any limit in GTA:SA itself.

TagsNo tags attached.

Activities

scarface1994

2009-03-15 19:59

viewer   ~~0008561

Been here since DP2, has been improved just not enough though.

Talidan

2009-03-15 20:03

administrator   ~~0008562

Last edited: 2009-03-15 20:04

This is because GTA streams out players at this distance, and remote players dont generate the shots. Perhaps its possible to hack it in.

[PS]DazzaJay[AU]

2009-03-16 05:33

reporter   ~~0008571

I was trying to make a map for testing how good new recruits into the clan are, and i made a sniper range, all the objects are eaisially seeable, but, only the closest 12 can be shot.

Really quite annoying. hopefully it can be hacked in.

eAi

2009-05-11 02:34

administrator   ~~0009196

Assigned this to Peter as I'm sure he'd love to fix this.

Issue History

Date Modified Username Field Change