View Issue Details

IDProjectCategoryView StatusLast Update
0004094Multi Theft Auto : San AndreasGUI / Menus / Consolepublic2009-08-23 02:05
ReporterjhxpAssigned Tomabako 
PrioritylowSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target Version1.0Fixed in Version1.0 
Summary0004094: Make Tab and Enter keys work in Options and Quick Connect windows
Description

As above. It would make filling fields in them more convenient for keyboard addicts.

Tab key should switch between fields in these windows, while Enter should accept changes and close the window (while in a text field).

TagsNo tags attached.

Relationships

has duplicate 0004387 closed Multi Theft Auto : San Andreas tabbing in gui inputs 
related to 0004366 resolvedCazomino05 Source patches Patch to allow Enter in Quick Connect fields, Browser's password field and Community Login 
related to 0004367 resolvedccw Source patches Tab Patch (for Issue 4094) 

Activities

Kaltsu

2009-03-15 19:13

viewer   ~~0008560

Agreed! Would really improve the usage of the menus.

Talidan

2009-03-16 03:33

administrator   ~~0008567

If there's a proper CEGUI implementation for this that you can find it would help. Doing this manually for each dialog would be annoying.

Cazomino05

2009-05-25 23:08

reporter   ~~0009381

mabako has fixed the enter key, just needs tab support now to close this issue

robhol

2009-05-29 18:22

reporter   ~~0009442

Since Johnline's issue was closed and marked as a duplicate, I'll quote him here, he does have a point.

"further from that quite a few text input conventions are missing, like shift+right/leftarrow/home/end to select, and ctrl/right/left to jump words. this would be particularly useful in console."

Issue History

Date Modified Username Field Change