View Issue Details

IDProjectCategoryView StatusLast Update
0003984Multi Theft Auto : San AndreasGeneralpublic2009-08-23 02:05
Reporterscarface1994Assigned ToArc 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version1.0Fixed in Version1.0 
Summary0003984: When changing to Cinematic camera mode, sometimes the camera gets placed at the current camera matrix
Description

When changing to cinematic camera, after driving away and the view changes and moves further to you, the camera sets a fix on an underground position, if you keep on driving until the camera should move further to you again then everything comes normal to the way it should, i don't know if I've explained myself well cause it's not so easy to, later I'll try and record a video.

Additional Information

Nightly r255

TagsNo tags attached.

Activities

scarface1994

2009-01-18 17:31

viewer   ~~0008309

Last edited: 2009-03-01 14:14

Ok I made the video http://www.xfire.com/video/67189/

mekorea

2009-02-22 21:04

developer   ~~0008413

Still in r333

Talidan

2009-03-15 01:17

administrator   ~~0008553

The camera actually gets set to where the Camera matrix is in fixed camera mode - setCameraMatrix to a desired position and you'll find that this random cinematic position is actually this specific position.

Cazomino05

2009-05-10 17:02

reporter   ~~0009150

Reproduced in r804, it happens pretty much as Talidan said as the position it appears at the same point.

Defiantly needs fixing before realise it looks really bad.

Issue History

Date Modified Username Field Change