View Issue Details

IDProjectCategoryView StatusLast Update
0003962Multi Theft Auto : San AndreasClientpublic2012-06-22 19:51
ReporterPaul_CortezAssigned Toccw 
PrioritynormalSeveritytweakReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version1.3.1Fixed in Version1.3.1 
Summary0003962: "Vehicle attachment bug"
Description

I've been experimenting with attaching vehicles to Andromada's, and it seems a little weird... The vehicle can be attached, but seems to fall/be launched off the Andromada.

See for yourself: (note: not really a that good quality vid, and not really a good daytime to do it...)

http://www.xfire.com/video/5aab1/

Additional Information

So how to reproduce:

-Have an Andromada and an Infernus (or any other vehicle)
-Attach them to eachother (for instance on the cargo thing)
-Fly away in the Andromada, the vehicle stays
-Fly a bit more, and make a large turn, and it'll sometimes just fall, and at other times be LAUNCHED off.

(version nightly r182)

TagsNo tags attached.

Relationships

has duplicate 0005627 closed New issues Vehicles fly away when atached to helicopters on planes. 

Activities

Talidan

2009-02-24 23:11

administrator   ~~0008422

Last edited: 2009-02-24 23:15

May be to do with the streamer. The game might think the vehicle is still in its original position and does some streaming out stuff when moving away.

Does this have to be done in a plane? Try reproducing with normal vehicles, and combinations of vehicle->player and vehicle->object.

Also, try to validate the attached vehicle's position (to see if the game is aware its moving with the plane)

Paul_Cortez

2009-02-25 16:21

reporter   ~~0008425

Last edited: 2009-02-25 17:28

Well, this seems to be happening with any vehicle, as long as it's X or Y rotation gets too far it seems. With about a 70-90 degree X or Y angle vehicles already seem to fire off. Upside-down seems totally impossible with vehicle attaching.

Weird thing is, when both vehicles are streamed out, it seems to be reattached. Although I didn't test this that often, it usually did when I did test it. There also seems minor desynch sometimes with one player seeing it attached and the other not seeing it.

Note that this was an server-side attachement. I'll test some more on this today and will edit this note whenever there's an important update.

EDIT: Ok, it doesn't happen when the vehicle is attached to a player or object. It only seems to be happening with vehicle+vehicle. It also doesn't only happen with airplanes, it also happens with normal vehicles. I've uploaded a new video to show this, and what actually happened on the plane.

http://www.xfire.com/video/8086d/

Vehicles don't seem to reattach when streamed out, instead it seems like one of the vehicles has to blow for it to do it.

x86

2009-10-30 14:06

administrator   ~~0010768

Isn't there a way to make the attached elements static, and restore it when calling detachElements, or when the atached element explodes ? ?

Remi-X

2012-03-27 17:48

reporter   ~~0016378

Last edited: 2012-03-27 22:45

I've been talking to someone today about this issue. I believe this is not a bug, but a GTA feature that is bothering us now.
Remember this singleplayer mission where you had to jack cars with a helicopter and magnet? I guess that this glue is what MTA uses for attachElements. Now, if you would make weirdass moves like Paul_Cortez did, the car would fall of from the magnet. Thus a feature, making it harder to fly with vehicles.
The vehicle will fall off after a certain rotation, just like it would in singleplayer.

My guess is to hax this feature around, making this rotation always a good rotation for GTA. I don't really know how this all works but I'm told that this will be done using ASM and some NOP's.

Indeed this bug only happens with vehicle<->vehicle.

EDIT: http://bugs.mtasa.com/view.php?id=6968 there :D

Issue History

Date Modified Username Field Change