View Issue Details

IDProjectCategoryView StatusLast Update
0003919Multi Theft Auto : San AndreasGeneralpublic2011-03-05 01:19
ReporterjhxpAssigned ToTalidan 
PrioritylowSeveritymajorReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target Version1.1Fixed in Version1.1 
Summary0003919: Implement support for unicode text
Description

Multi Theft Auto currently lacks good support for Unicode text (chatbox, etc.). This should solve problems with supporting specific regional characters (e.g. Cyrillic, Central European, Asian).

TagsNo tags attached.

Relationships

parent of 0003084 closed Multi Theft Auto : San Andreas CMainMenu.cpp assertion just before main menu is loaded 
has duplicate 0004940 closed New issues MTA 1.0 released, and when the promised unicode support? 
related to 0004799 resolvedryden Source patches Cyrillic symbols in chat and input line 
child of 0003344 closed New Feature Requests Requested features tracker 

Activities

eAi

2010-06-01 01:12

administrator   ~~0011535

Some work is being done on this.

ZZiGGi

2010-07-03 08:14

viewer   ~~0011678

It is very need.

toneysix

2010-07-10 19:08

viewer   ~~0011725

Last edited: 2010-07-10 19:08

I also support this idea. I'm from Russia.
Regards Nikita.

d0lph1n

2010-08-11 13:58

viewer   ~~0011951

So, when Unicode branch will be merged with trunk?

QuantumZ

2010-08-11 14:01

viewer   ~~0011952

But unicode text for chatbox should have a function to disable or enable it. Think at the spam... of russians, chinese people etc... I mean for english servers.

onestone

2010-08-11 14:48

viewer   ~~0011953

No. You can also spam with english or other languages...

arranTuna

2010-08-19 11:14

manager   ~~0011982

There is no need for a function to enable/disable it - because if you really want you can block certain characters in chat through scripting.

A table of characters you want to block and then on chat you loop through the charachters you want to block and use string.find to search the string for the character, if found then cancel event.

Talidan

2011-03-05 01:19

administrator   ~~0013028

This is more or less complete. Any remaining bugs should be reported seperately.

Issue History

Date Modified Username Field Change