View Issue Details

IDProjectCategoryView StatusLast Update
0003918Multi Theft Auto : San AndreasScriptingpublic2009-08-23 02:13
ReporterWillyAssigned ToJax 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version1.0Fixed in Version1.0 
Summary0003918: setPedAnimations not being "interruptable"
Description

When setting a ped animation on your player, interrupting it, and then setting it again makes the animation not interruptible.

Steps To Reproduce

crunc setPedAnimation(getLocalPlayer(),"Flowers", "Flower_attack")

jump or move to interrupt the animation

crunc setPedAnimation(getLocalPlayer(),"Flowers", "Flower_attack")

or

crunc setPedAnimation(getLocalPlayer(),"Flowers", "Flower_attack", -1, true, true, true)

you can no longer interrupt the animation

You can get out of the animation by doing:

crunc setPedAnimation(getLocalPlayer())

NB: manually setting the argument "bool interuptable=true" doesn't fix this.

TagsNo tags attached.

Activities

Talidan

2009-02-19 01:59

administrator   ~~0008397

Last edited: 2009-02-19 02:38

Just to clarify it seems only the first animation of each block is ever interuptable. You have to restart the game before you can interupt an animation again in that block.

Not sure why it affects the whole block but either way its definitely present.

Also, this doesnt seem to be due to MTA's method of disabling interuption (killing higher priority tasks), it seems to be due to the animation setting itself.

edit: doesnt seem to be just restarting the game. if you get in a car and drive around for a while you can do it again. Not sure why. You cant simply sit in the car for a while either, i've had to drive around. I found that driving 800 coordinates away from the last time i tried was reliable enough to allow me to interupt animations again. I also tried sprinting 800 coords, which didnt work.

BigBadButler

2009-03-25 12:54

viewer   ~~0008628

Is it the time you needed for those 800 units or is it the 800 units themselves?

Jax

2009-06-01 12:27

administrator   ~~0009482

If you set the time to -1 the anim will be uninteruptable

Issue History

Date Modified Username Field Change