View Issue Details

IDProjectCategoryView StatusLast Update
0003754Multi Theft Auto : San AndreasScriptingpublic2009-08-23 02:00
Reportererorr404Assigned ToJax 
PrioritylowSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target Version1.0Fixed in Version1.0 
Summary0003754: feature: setting animation intervals
Description

There should be interval arguments (startTime, stopTime) for setPedAnimation() so that you could run only a specific part of an animation rather than the whole thing.

Additional Information

This can be useful in various cases. For example, I'm trying to make a shotgun knockdown script to replicate the shotgun fights in gta3/vc, but the only get-up animations that exist also cause the player to fall down at the begginning (or otherwise start from a standing-up state). If I could use a seperate fall-down animation, and cut the get-up animations to only run the getting up part, that would make it look a lot better (since I could make the player start from a falling down state, rather than having him fall down again when he is already on the ground as he would if you run the get-up animation from the beginning).

TagsNo tags attached.

Relationships

child of 0003344 closed New Feature Requests Requested features tracker 

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change