View Issue Details

IDProjectCategoryView StatusLast Update
0003482Multi Theft Auto : San AndreasScriptingpublic2011-05-29 16:41
Reporterlil_ToadyAssigned ToJax 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version1.1 
Summary0003482: request: onClientKey ( state )
Description

triggered client side when user pressed/releases a key

would be good to fetch inputs with special chars like !@#$%^&*()_+{} etc. (As i heared some of those are located under diff keys on some keyboards)

TagsNo tags attached.

Relationships

has duplicate 0004092 closed New issues Client events: onClientKeyboard* 
child of 0003344 closed New Feature Requests Requested features tracker 

Activities

Jax

2009-08-24 10:48

administrator   ~~0010348

Im not sure why you've reopened these.

IJs

2009-12-12 00:01

administrator   ~~0010853

http://github.com/multitheftauto/multitheftauto/commit/3ef02ef219d4ddd7a5b12152193ed58a331a5f15

Commit has to be checked and re-merged into git.

Remi-X

2010-11-26 23:28

reporter   ~~0012195

It's already a year later, and MTA 1.1 is coming. Still I think this kind of event would be really useful, so we don't have to bind all for some stuff, or checking every frame for a press and handle that with care.

QuantumZ

2010-11-28 22:12

viewer   ~~0012212

I have to agree with Remi-X. Will be very useful.

MX_Master

2010-12-11 19:27

viewer   ~~0012247

i think you want to make with this something like key handler for custom input (: for example for non-latin chars..

Jockie

2011-03-05 00:57

viewer   ~~0013022

Last edited: 2011-03-22 15:56

I need this event. o.o

Using bind keys while guiSetInputEnabled is set to true fails.

TheGTA

2011-03-06 07:30

updater   ~~0013033

I have to have this event! My Resource Manager would receive a speed up since I could perform some more complex logic without the need of a gui-memo.

The event shall give the correctly formatted input as suggested :)

ccw

2011-03-24 00:11

administrator   ~~0013102

Reapplied Jax's fix: http://code.google.com/p/mtasa-blue/source/detail?r=2480

Jockie

2011-03-24 20:50

viewer   ~~0013108

Last edited: 2011-03-24 20:53

Tested the nightly, but there is 1 small bug.
The ' key (Between ; and \ @ US QWERTY) returns #.

It should also be possible to retrieve the keys when the Shift button is pressed.
Like upper.case chars and Shift-chars, because when someone wants to create a sort of "Editable dxDrawText" could someone might have an other type of keyboard and those keys won't match anymore by then.

TheGTA

2011-05-29 16:41

updater   ~~0013515

Still waiting for special characters :/

Issue History

Date Modified Username Field Change