View Issue Details

IDProjectCategoryView StatusLast Update
0003457Multi Theft Auto : San AndreasVehiclespublic2011-07-09 00:54
ReporterrydenAssigned ToCazomino05 
PrioritylowSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Versionblue_sa.r2.a12 
Target Version1.1Fixed in Version1.1 
Summary0003457: request: Complete handling function set
Description

There are some more interesting functions in GTA's handling.cfg, like the seat position or disabling the handbreak.

I copy in "Additional Information" these features

Additional Information

; (aa) fSeatOffsetDistance // ped seat position offset towards centre of car
;
; (af) modelFlags!!! WARNING - Now written HEX for easier reading of flags
;
; 1st digit 1: IS_VAN 2: IS_BUS 4: IS_LOW 8: IS_BIG
; 2nd digit 1: REVERSE_BONNET 2: HANGING_BOOT 4: TAILGATE_BOOT 8: NOSWING_BOOT
; 3rd digit 1: NO_DOORS 2: TANDEM_SEATS 4: SIT_IN_BOAT 8: CONVERTIBLE
; 4th digit 1: NO_EXHAUST 2: DOUBLE_EXHAUST 4: NO1FPS_LOOK_BEHIND 8: FORCE_DOOR_CHECK
; 5th digit 1: AXLE_F_NOTILT 2: AXLE_F_SOLID 4: AXLE_F_MCPHERSON 8: AXLE_F_REVERSE
; 6th digit 1: AXLE_R_NOTILT 2: AXLE_R_SOLID 4: AXLE_R_MCPHERSON 8: AXLE_R_REVERSE
; 7th digit 1: IS_BIKE 2: IS_HELI 4: IS_PLANE 8: IS_BOAT
; 8th digit 1: BOUNCE_PANELS 2: DOUBLE_RWHEELS 4: FORCE_GROUND_CLEARANCE 8: IS_HATCHBACK
;
; (ag) handlingFlags - written in HEX
;
; 1st digit 1: 1G_BOOST 2: 2G_BOOST 4: NPC_ANTI_ROLL 8: NPC_NEUTRAL_HANDL
; 2nd digit 1: NO_HANDBRAKE 2: STEER_REARWHEELS 4: HB_REARWHEEL_STEER 8: ALT_STEER_OPT
; 3rd digit 1: WHEEL_F_NARROW2 2: WHEEL_F_NARROW 4: WHEEL_F_WIDE 8: WHEEL_F_WIDE2
; 4th digit 1: WHEEL_R_NARROW2 2: WHEEL_R_NARROW 4: WHEEL_R_WIDE 8: WHEEL_R_WIDE2
; 5th digit 1: HYDRAULIC_GEOM 2: HYDRAULIC_INST 4: HYDRAULIC_NONE 8: NOS_INST
; 6th digit 1: OFFROAD_ABILITY 2: OFFROAD_ABILITY2 4: HALOGEN_LIGHTS 8: PROC_REARWHEEL_1ST
; 7th digit 1: USE_MAXSP_LIMIT 2: LOW_RIDER 4: STREET_RACER
; 8th digit 1: SWINGING_CHASSIS
;
; (ah) front lights (0 = long, 1 = small, 2 = big, 3 = tall)
; (ai) rear lights (0 = long, 1 = small, 2 = big, 3 = tall)
; (aj) vehicle anim group

TagsNo tags attached.

Relationships

related to 0005269 resolvedFlobu Multi Theft Auto : San Andreas 1.0.4 Custom - Flobu's Build: Default Handling Is Incorrect. 
parent of 0005759 resolvedCazomino05 Multi Theft Auto : San Andreas [Handling] Limits required on handling properties 
parent of 0005761 resolvedCazomino05 Multi Theft Auto : San Andreas [Handling] certain properties don't work or are useless 
parent of 0005922 resolvedCazomino05 Multi Theft Auto : San Andreas [Handling] Add functions for handling and model flags 
parent of 0005921 resolvedArc Multi Theft Auto : San Andreas [Handling] RecalculateSuspension recalculates all vehicles of that model 
has duplicate 0004417 closed New issues Request: setVehicleLimit() 
has duplicate 0005048 closed New issues Removing the aircrafts height limit 
related to 0004388 closed New issues Request: setVehicleMaxSpeed(vehicle, maxspeed) 
child of 0003344 closed New Feature Requests Requested features tracker 

Activities

Flobu

2010-03-29 18:46

updater   ~~0011286

but its only not synced clientside

Mr.Hankey

2010-03-29 19:43

reporter   ~~0011287

As i already said on irc: This is by far not finished yet.
Flobu and me are going to try fixing it up in the near future though.

Maccer

2010-03-30 06:59

viewer   ~~0011290

You might want to add this as a relationship: http://bugs.mtasa.com/view.php?id=5269

Also, Johnline recommends adding a vehicle.ide function set, since it contains wheel size, ( . . . ) and all of the physical entities of the vehicle.

Cazomino05

2011-01-03 23:36

reporter   ~~0012437

Doing a quick run through now think the problem is either that the packets aren't being sent or a faulty if statement the array offset seems right I'll post back when I'm finished

Cazomino05

2011-01-06 07:51

reporter   ~~0012470

issues:

1) invalid handling results in no handling
2) handling isn't per vehicle with setVehicleHandling it just sets for the entire model try setting the dragCoeff to 700 which makes driving very hard then spawn another vehicle of the same model and it will have the same properties
3) needs upper and lower bound limits to prevent crashes

Cazomino05

2011-01-06 09:03

reporter   ~~0012471

Last edited: 2011-01-06 09:04

fixed 2 - see r2267 http://code.google.com/p/mtasa-blue/source/detail?r=2267

also noticed we don't sync handling on join

Cazomino05

2011-01-06 09:24

reporter   ~~0012472

Last edited: 2011-01-06 09:25

engine type is sparks/smoke related electric makes those yellow particles like on the caddy while driving and I can confirm works

on a side note this doesn't update automatically when the smoke is already there repairing the vehicle and setting it smoking again will update it

XX3

2011-01-23 16:27

viewer   ~~0012698

I ever mod GTA SA and most of the car mods need to edit vehicles.ide and handling in order to edit the vehicle's entity adjustments to fit the car specs perfectly.

So, I confirm to Johnline's recommendation. I'm not sure this will finish in time if you include vehicles.ide settings.

Cazomino05

2011-02-12 00:22

reporter   ~~0012914

Last edited: 2011-02-12 00:22

CHandlingData struc ; (sizeof=0xC624)
00000000 field_0 dd ?
00000004 field_4 dd ?
00000008 field_8 dd ?
0000000C field_C dd ?
00000010 field_10 dd ?
00000014 vehicleHandling CHandlingVehicle 210 dup(?)
0000B7D4 bikeHandling CHandlingBike 13 dup(?) ; ñ½´ »«½ÒþÑ¡¿´ ¡Òª¡«® ßÔÓÒ¬ÔÒÓÙ ¿º ¿¡ñѬßá óÙþ¿ÔáÑÔß´ 162
0000BB14 flyingHandling CHandlingFlying 24 dup(?)
0000C354 boatHandling CHandlingBoat 12 dup(?)
0000C624 CHandlingData ends

CHandlingBike struc ; (sizeof=0x40)
00000000 index dd ? ; index ó ß»¿ß¬Ñ ¿¼Ñ¡
00000004 leanFwdCOM dd ?
00000008 leanFwdForce dd ?
0000000C leanBakCOM dd ?
00000010 leanBakForce dd ?
00000014 maxLean dd ?
00000018 fullAnimLean dd ?
0000001C desLean dd ?
00000020 speedSteer dd ?
00000024 slipSteer dd ?
00000028 noPlayerCOMz dd ?
0000002C wheelieAng dd ?
00000030 stoppieAng dd ?
00000034 wheelieSteer dd ?
00000038 wheelieStabMult dd ?
0000003C stoppieStabMult dd ?
00000040 CHandlingBike ends
00000040
00000000 ; ---------------------------------------------------------------------------
00000000
00000000 CHandlingFlying struc ; (sizeof=0x58)
00000000 index dd ?
00000004 thrust dd ?
00000008 thrustFallOff dd ?
0000000C yaw dd ?
00000010 yawStab dd ?
00000014 sideSlip dd ?
00000018 roll dd ?
0000001C rollStab dd ?
00000020 pitch dd ?
00000024 pitchStab dd ?
00000028 formLift dd ?
0000002C attackLift dd ?
00000030 gearUpR dd ?
00000034 gearDownL dd ?
00000038 windMult dd ?
0000003C moveRes dd ?
00000040 turnRes RwV3D ?
0000004C speedRes RwV3D ?
00000058 CHandlingFlying ends
00000058
00000000 ; ---------------------------------------------------------------------------
00000000
00000000 CHandlingBoat struc ; (sizeof=0x3C)
00000000 index dd ?
00000004 thrustY dd ?
00000008 thrustZ dd ?
0000000C thrustAppZ dd ?
00000010 aqPlaneForce dd ?
00000014 aqPlaneLimit dd ?
00000018 aqPlaneOffset dd ?
0000001C waveAudioMult dd ?
00000020 look_L_R_BehindCamHeight dd ?
00000024 moveRes RwV3D ?
00000030 turnRes RwV3D ?
0000003C CHandlingBoat ends

may be worth adding

Cazomino05

2011-05-04 03:33

reporter   ~~0013291

By filing this bug you have questioned my family honor. Prepare to die!

Cazomino05

2011-05-04 03:41

reporter   ~~0013292

oh and not long now

Remi-X

2011-05-04 17:32

reporter   ~~0013304

Little question, will there be support for boats/planes/bikes handling? Since the base-handling can only be editted now, and not the additional handling for boats etc.

Cazomino05

2011-05-04 20:31

reporter   ~~0013308

problem I see is it'l introduce more bugs as I'm pretty sure most won't work natively which involves more hacks which pushes back the release date

Remi-X

2011-05-04 20:32

reporter   ~~0013309

Maybe a nice feature for later, when the basic stuff is finished then.

Remi-X

2011-05-15 14:46

reporter   ~~0013411

On r2667:
Just did some change to the suspension, and got a LSOD. /kill crashes the game, and trying to connect again gives fatal error 6.
This might be a bug of the handlingfuncs, never had such a thing before. I'm not sure though, but it might be worth mentioning.

Vehicle: Bullet
Changed values in order: centerOfMass[0,0,1] - suspensionUpperLimit[1] - suspensionLowerLimit[1] > lsod

Cazomino05

2011-05-16 18:29

reporter   ~~0013416

/kill crashing is a bug when the trunk was merged

Issue History

Date Modified Username Field Change