View Issue Details

IDProjectCategoryView StatusLast Update
0003252Multi Theft Auto : San AndreasSynchronizationpublic2012-01-24 19:44
Reporterlil_ToadyAssigned ToCazomino05 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version 
Target Version1.3Fixed in Version1.3 
Summary0003252: Heat seekers sync isn't accurate
Description

If somebody shoots you, you can be lucky to get rid of the rocket itself so it flies in another direction but you will still get an explosion in the back like if it hit you

TagsNo tags attached.

Relationships

parent of 0004988 resolvedCazomino05 createProjectile() velocity desync between clients 

Activities

Jax

2008-02-19 05:29

administrator   ~~0007287

Last edited: 2008-02-19 06:26

Some other projectiles' explosions aren't affected by remote actions either, eg: grenades being shot away.
Maybe heatseaking rocket explosions could be sync'd from the targeted player, we can't tell who that is in the explosion event yet though.

Cazomino05

2011-10-09 19:43

reporter   ~~0015060

0x738B20 looks like CProjectile_Process

  • 0x739295 moves the projectile array to ebp
  • 0x73929A moves another projectile related array to edi (it's called by LaunchSAMRocket a lot)
  • It's called by sub_73A360 which in turn is called by CGame__Process
  • Check the very frequent player/vehicle checks as they seem very odd.

Picard

2012-01-13 18:53

updater   ~~0015726

Issue automatically marked as fixed by mantisbot ( Fixed in http://code.google.com/p/mtasa-blue/source/detail?r=3683 )

Issue History

Date Modified Username Field Change