View Issue Details

IDProjectCategoryView StatusLast Update
0003022Multi Theft Auto : San AndreasScriptingpublic2014-09-01 03:57
ReporterLucif3rAssigned ToCazomino05 
PrioritynoneSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target Version1.4.1Fixed in Version1.4 
Summary0003022: Scripting functions for creating bullets/shots
Description

I would like to request a createBullets() function, similar to createProjectile().

The arguments should be similar to createProjectile aswell. But, i would also like an argument to make it "static", which means it would only fire straight forward based on the players rotation, rather than camera rotation.

This would make interstate69 pretty awsome tbh.

The weapon "types" i'd like is minigun and M4/AK, but i wouldnt cry for more types :>

TagsNo tags attached.

Relationships

child of 0003344 closed New Feature Requests Requested features tracker 

Activities

ChrML

2008-01-04 23:50

administrator   ~~0007017

I can probably add these kinds of functions with a source position, target position, damage specifyers, intervals, counts etc.. serverside and a simpler one clientside around the time we do peds.

Kernell

2012-06-16 14:43

reporter   ~~0016821

0x735FD0 - void cdecl CBulletreleaseAll()

0x736010 - bool cdecl CBulletcreate(CPed *pEntity, short sWeaponType, float fOriginX, float fOriginY, float fOriginZ, float fVelocityX, float fVelocityY, float fVelocityZ)

Cazomino05

2012-06-16 14:47

reporter   ~~0016822

already working on it with custom-weapons anyway

Kernell

2012-06-16 14:49

reporter   ~~0016823

nice :)

Cazomino05

2012-06-21 16:21

reporter   ~~0016869

Last edited: 2013-02-02 15:41

hi

Cazomino05

2012-06-21 16:23

reporter   ~~0016870

There is no way in hell I'll put this in 1.3.2 now as I planned either.

sbx320

2014-09-01 03:57

administrator   ~~0021901

Fixed since 1.4 by the introduction of createWeapon etc.

Issue History

Date Modified Username Field Change