View Issue Details

IDProjectCategoryView StatusLast Update
0002874Multi Theft Auto : San AndreasGeneralpublic2011-01-26 01:30
ReporterslothmanAssigned ToArc 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Versionblue_sa.r2.a12 
Target Version1.0Fixed in Version1.0 
Summary0002874: Custom TXD and/or COL loading issues
Description

heres the script:

function clientsetup (resource)
if resource ~= getThisResource() then return end
txd_shield = engineLoadTXD("riot_shield.txd")
engineImportTXD(txd_shield,2168)
col_shield = engineLoadCOL("riot_shield.col")
dff_shield = engineLoadDFF("riot_shield.dff" )
engineReplaceCOL(col_shield,2168)
engineReplaceModel(dff_shield,2168)
end

addEventHandler ( "onClientResourceStart",getRootElement() , clientsetup)

the object itself is created and deleted when the player pushes and releases a button. the first time the script is loaded for a player, the col works but the texture doesn't. if i stop the script and restart it, then the texture loads but the col doesn't.

TagsNo tags attached.

Relationships

related to 0003064 resolvedArc Multi Theft Auto : San Andreas textures dont load for custom objects unless the object already exists and is streamed in for the player 
related to 0004302 closed New Feature Requests [Request] col library support 

Activities

AlienX

2008-01-04 02:42

viewer   ~~0007004

With this issue (using resource wipeout on my testing server) i have noticed that the COL can be loaded properly if done in a certain order...

First load the TXD (which dnt work)
Then load the COL
Then load the models
then load the COL again...

This seems to fix it for me.

jhxp

2008-12-01 11:20

administrator   ~~0008206

Last edited: 2008-12-01 12:51

Is this still an issue?

To be verified on 1.0 .

1337MaVe

2009-03-28 23:39

viewer   ~~0008684

I couldn't reproduce it in r567

IJs

2009-04-17 20:30

administrator   ~~0008835

Is this still an issue?

Arc

2009-04-17 20:36

administrator   ~~0008837

Yes, I've heard people say that while txd's are pretty much fixed, collisions are not.

scarface1994

2009-04-17 21:33

viewer   ~~0008838

As arc_ has just stated, it's the collisions that are not yet fixed.

ryden

2009-05-08 01:40

manager   ~~0009094

Is this already fixed?

scarface1994

2009-05-08 21:39

viewer   ~~0009098

Most of the TXD bugs seem to be fixed but the COL's are a disaster!

Arc

2009-05-08 21:40

administrator   ~~0009099

Last edited: 2009-05-08 21:40

Still? I added a possible fix in last nightly (r789)

Talidan

2009-05-08 21:40

administrator   ~~0009101

Cols seem to work almost perfectly here. Perhaps you're not calling the functions right.

The only issue currently is that col libraries are not supported.

scarface1994

2009-05-08 22:27

viewer   ~~0009102

Don't know, but if you join Gamesnert's server now, we could show you.

IJs

2009-05-09 16:48

administrator   ~~0009115

Status?

Arc

2009-05-09 16:55

administrator   ~~0009116

The resource in Gamesnert's server used col libraries apparently. Not sure if we should support those. In any case Slothman should retest his shield.

IJs

2009-05-09 16:56

administrator   ~~0009117

Might we worth noting the support of COL libraries in the Wiki (on the appropriate function pages).

subenji99

2009-05-10 20:02

viewer   ~~0009157

In testing getting the well-known "SAkina" custom model into MTA, I found that replacing a COL file would fail with a v1 COL file. After splitting the COL library into seperate files, I had to edit one of the COL sections to conform to COL v2 and v3 size limitations.

http://www.gtamodding.com/index.php?title=Collision_File

Arc

2009-05-10 20:03

administrator   ~~0009158

MTA only supports version 3 collision files.

subenji99

2009-05-10 20:58

viewer   ~~0009165

The wiki was not very clear on that - all I found is this in http://development.mtasa.com/index.php?title=COL
The COL class represents a RenderWare Collision File (COL3) loaded by the client

But that's not clear to people (including myself until recently) what a COL3 Collision file is.
It should also include that information on not supporting collision libraries, and possibly a link to http://ce2.steve-m.com/ as a solution to converting the collision models.

Cazomino05

2009-05-10 20:59

reporter   ~~0009166

Last edited: 2009-05-10 21:00

http://development.mtasa.com/index.php?title=EngineReplaceCOL
"Note: collision libraries (.col files containing multiple collision models) are not supported at the moment."
that has been there for over a day.

Arc

2009-05-11 00:49

administrator   ~~0009185

<Cazomino05> i just tested cols with Slothman and it works fine

jack9267

2011-01-26 01:30

viewer   ~~0012760

I'm using col2 on my server works perhaps I should use col3?

Issue History

Date Modified Username Field Change