View Issue Details

IDProjectCategoryView StatusLast Update
0002612Multi Theft Auto : San AndreasScriptingpublic2009-12-07 00:19
ReportersinnergAssigned Toccw 
PriorityurgentSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Versionblue_sa.r2.a12 
Target Version1.0.1Fixed in Version1.0.1 
Summary0002612: Spawning a player within the ground may damage the player a tiny bit on spawn, with false damage information.
Description

When I killPlayer() someone (for example : when I headshot him) and he respawns the first time, he receives another 0.39999961853027 damage on spawn with same attacker, weapon and bodypart (causing him to die again at my code)

  • This only occurs on 1st respawn, 2nd respawn everything is ok and the player does not receive the small amount of damage

Also, this bug does not occur when the player who got killed has build mtasaa12-summoned-20071021 (arc tested this with me)

Additional Information

Ok, looks like bad-placed spawns cause this (aka middle point 'in the ground')

But still it shouldnt report the 'attacker' as the one who attacked the player the last time + the fact that it didnt 'trigger' with the attacker set before (the mentioned revision)

I worked around atm (except the damage sound) but atleast <0.5 dmg wont trigger the killPlayer another time now :)

TagsNo tags attached.

Relationships

related to 0002593 resolvedJax killing a player (killPlayer()) with armor needs to be triggered twice (and another bug) 

Activities

Talidan

2007-10-22 20:01

administrator   ~~0006044

Sounds a lot like hunger to me. Hunger takes damage and MTA assumes the damage is due to the last valid attack event - in other words, if a player gets shot with an m4 in the head, then loses hp from hunger, MTA will report it as being shot in the head with an m4 again.

This doesnt necessarily mean its hunger which is causing this. It could mean that, like hunger, the loss does not have an associated ID so MTA assumes it wrong.

sinnerg

2007-10-22 20:04

reporter   ~~0006047

Happens everytime with current build, didn't occur with previous build. And afaik, hunger is a GTA thing so I don't think that got changed.

Talidan

2007-10-22 20:07

administrator   ~~0006049

Then perhaps its to do with velocity being reset. The reason it could cause slight damage 1st spawn and not 2nd is because the map has not streamed in yet. Try reproducing it by moving far away from the map and see if the player gets damaged the 2nd and 3rd time.

Talidan

2007-11-11 16:39

administrator   ~~0006198

still here?

jbeta

2007-11-11 18:04

updater   ~~0006209

Can't reproduce with runcode: I tried outputting both client and server damages, ran killPlayer on myself, respawned using spawnPlayer, and nothing would output then.

eAi

2007-11-14 20:53

administrator   ~~0006280

If this can't be reproduced in a few days, we'll close this issue.

AlienX

2007-11-26 03:46

viewer   ~~0006454

Will check 2nite & close myself if i cannot re-produce.

sinnerg

2007-11-29 13:28

reporter   ~~0006514

Last edited: 2007-11-29 14:19

Howto test:

1) join a server
2) gamemode teamwars tw_cp-city
3) rejoin (didnt fix menu yet)
4) start mantis2612
5) join any team as any class
6) you should receive damage on first spawn (the 'underground spawn' dmg)
7) let someone kill you
8) on respawn, you'll receive a bit of damage again, and notice the attacker is set to the person who last killed you (instead of 'falldamage' aka no attacker)

Jax

2007-12-01 09:03

administrator   ~~0006541

Find out what the arguments are for client and server side in the damage event

sinnerg

2007-12-02 09:59

reporter   ~~0006560

Also noticed something similar on TeamWars with the terrorist.

His ability is to slowly lose HP and on death he goes BOOM!

When I kill a terrorist, and he respawns, I constantly get beep tones as if I'm damaging him, while I'm not (he's actually losing hp using setElementHealth since that is his ability :P)

sinnerg

2007-12-16 15:37

reporter   ~~0006794

Bug still exists, could use some help to test it tho... @ Server side it just uses the last 'valid' damage info (attacker / weapon / bodypart)

ChrML

2007-12-16 18:53

administrator   ~~0006808

Seen it myself. Surely this can be prevented by not making bad spawns though? Not sure how to fix this.

Talidan

2007-12-23 12:57

administrator   ~~0006851

I've bumped priority. This is a major issue, affecting every gamemode. I've experienced this in CTF, Stealth, Teamwars, battlefield, tdma...

This bug is the cause of the dreaded death on spawn issue, and has been a consistent complaint throughout all mass tests.

Needs to be addressed asap.

ChrML

2007-12-29 15:53

administrator   ~~0006925

Surely the bad spawns is a gamemode issue? How GTA takes damage of players due to their positions is really out of our control, though damage information should probably be reset on spawn.

Jax

2008-04-02 06:21

administrator   ~~0007587

Re-test this

Issue History

Date Modified Username Field Change