View Issue Details

IDProjectCategoryView StatusLast Update
0002501Multi Theft Auto : San AndreasGeneralpublic2012-01-24 22:01
ReporterslothmanAssigned Toccw 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Versionblue_sa.r2.a12 
Target Version1.3Fixed in Version1.3 
Summary0002501: stopping certain gamemodes causes laffy-taffy cj or textureless player bug
Description

ever since the crash on gamemode stop bug was solved, when i stop the stealth gamemode, the local player turns into a laffytaffy cj. if you change the skin to something else, then back to the same model id, the player model is fine, but theres no texture (all white)

there are no visual player stats set in stealth. only weapon stats and the underwater breathing stat. I tested this with tdma, but it did not happen.

TagsNo tags attached.

Relationships

related to 0002659 resolvedJax resetMapInfo() changes skin to CJ while server is not aware of this. 

Activities

jbeta

2007-09-12 19:22

updater   ~~0005699

The map manager calls resetMapInfo() on gamemode stop, it's likely to be the cause.

slothman

2007-10-12 17:47

updater   ~~0005965

issue has returned with textureless players when a gamemode is stopped

Talidan

2007-10-13 19:31

administrator   ~~0005968

i think we need setPlayerSkin serverside again. There's no practical way for player stats to be reset safely otherwise.

If this is done, resetMapInfo() can either be tweaked, or scripted entirely.

ChrML

2007-11-11 15:20

administrator   ~~0006194

White skin bug is probably fixed now. Reopen if it appears next nightly. Not sure about laffytaffy CJ but create a new report if that still happens.

BinSlayer

2010-08-19 00:09

viewer   ~~0011981

This bug still persists even in the latest 1.0.4 nightly. We have a skin changing system (Mr.Green race server) and if you change, after some time (really randomly happening) the skin is all white like the textures are missing or something.
Haven't been able to find a way to reproduce this but after a few race maps it does happen. The bug is only for clients and doesn't have to everyone at the same time.. We're not using custom skins btw
Regards

LooooP

2010-08-19 18:07

reporter   ~~0011983

Idd, here still too

Issue History

Date Modified Username Field Change