View Issue Details

IDProjectCategoryView StatusLast Update
0002323Multi Theft Auto : San AndreasGUI / Menus / Consolepublic2009-08-23 02:00
ReporterSintaxAssigned ToTalidan 
PrioritylowSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Versionblue_sa.r2.a12 
Target Version1.0Fixed in Version1.0 
Summary0002323: Settings menu only changes key bound to "down" state when rebinding commands bound to both states of the same key
Description

I remapped the control to view the radar map from F11 to 'x' (although I tried F10 also) and the map does not disappear when the button is released or pressed again. Resetting the control to F11 can fix this.

TagsNo tags attached.

Relationships

related to 0002307 closed Problems for the radar_attach control(s) 

Activities

jbeta

2007-08-31 16:01

updater   ~~0005529

The issue is that the radar command is bound with two different parameters to the same key. While you can change it manually ("/bind f10 down radar 1", then "/bind f10 up radar 0"), the settings menu only changes the first bound command, leaving the disappear command bound to f11.

Talidan

2007-11-26 16:39

administrator   ~~0006465

perhaps the default bind for radar should be "bind f11 down radar -1". This way it acts as a toggle (much less annoying than holding it down), plus it can be rebound without worrying about the "up" state not being bound.

Talidan

2008-12-22 05:55

administrator   ~~0008252

The original issue has now been solved, so this can be left for another release.

Talidan

2009-03-22 16:35

administrator   ~~0008597

Alongside scripted commands this issue becomes more prominent.

Issue History

Date Modified Username Field Change