View Issue Details

IDProjectCategoryView StatusLast Update
0002046Multi Theft Auto : San AndreasSynchronizationpublic2019-06-29 11:20
Reportererorr404Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionsuspended 
Product Versionblue_sa.r2.a12 
Target VersionFixed in Version 
Summary0002046: No climbing anim
Description

90% of the time when I see remote players climbing onto a ledge (or hanging from it), the proper animation doesn't show. Instead they're stuck in a non-changing falling animation until they get up or jump back down.

TagsNo tags attached.

Users sponsoring this issue
Sponsors List Total Sponsorship = EUR 10

2012-05-25 22:56: arranTuna (EUR 10)
Users sponsoring this issue (Total Sponsorship = EUR 10)

Activities

IJs

2007-07-12 10:42

administrator   ~~0005089

Needs verification.

BB101

2007-07-12 12:39

reporter   ~~0005101

Unless you changed anything about this since 11, still exist

ChrML

2007-11-19 08:26

administrator   ~~0006379

Probably need to do hanging from a cliff state syncing for this to be fixed. Currently it relies on our keysync.

erorr404

2008-01-28 22:40

developer   ~~0007186

This is a pretty ugly bug, in terms of the community's expectations about the sync, I will raise it's priority slightly.

Ransom

2008-04-18 08:09

administrator   ~~0007648

From ryden: I don't know the correct word, but when you start jumping a wall you stay attached to it until you press jump again to end climbing it. If you stay in that attached position and a player that was out of stream goes near you, he will see you floating and not with the proper animation.

arranTuna

2013-01-21 18:29

manager   ~~0017994

Last edited: 2013-01-21 18:33

This happens no where near as much as it used to, the only way to reproduce it nowadays is when you're not in their streaming range when they're hanging meaning this bug is only noticeable when:

  1. Somebody remains hanging for a very long time
  2. You get warped to them and see it for about a second

I'd remove my sponsorship if I could, since I no longer consider this significant.

LooooP

2013-01-21 18:36

reporter   ~~0017995

^ I still can see this happening when a player runs to a wall and climbs fast, he floats for a while then warps to the right position

arranTuna

2014-04-02 18:57

manager   ~~0020546

Last edited: 2014-04-02 18:59

View 2 revisions

I've made a video which shows some common, but random, poorly synced climbing animations.

To try and be more helpful I made a sync debug script which shows what controls are being synced to me while recording but this is only in the last part of the video but it shows a serious case of desync first with the player sliding along the ground which is also a common desync bug and then the jump is completely messed up.

Which control state the arrows are referring to in the video:

Forwards: Up arrow
Backwards: Down arrow
Left: Left arrow
Right: Right arrow
Jump: Half circle arrow
Sprint: Up arrow with extra line in it

Also, the video is playing at 0.5x speed since it's all over too quickly to get a good look at it on full speed.

https://www.youtube.com/watch?v=CRBoijyKVFw

ALBANDER

2016-06-16 16:58

viewer   ~~0024818

Why this bug will fixed in 1.6

it is important

qaisjp

2019-06-29 11:20

administrator   ~~0027107

Moved to https://github.com/multitheftauto/mtasa-blue/issues/1016

Issue History

Date Modified Username Field Change