View Issue Details

IDProjectCategoryView StatusLast Update
0000182Multi Theft Auto : San AndreasGeneralpublic2018-02-21 00:17
ReporterjhxpAssigned Toqaisjp 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformPCOSWindows XP ProOS VersionSP2
Product Version 
Target VersionFixed in Version1.5 
Summary0000182: Vehicle sirens/lights not flashing when on ground
Description

As above. See bugnotes and duplicate issue for more info.

TagsNo tags attached.

Relationships

has duplicate 0003631 closed Emergency vehicle lights don't work in the daytime sometimes/control of one vehicle's lights from another 

Activities

jhxp

2005-09-14 18:24

administrator   ~~0000571

If you didn't saw what i meant:
Try driving a police car in sp, and activate the sirens. You'll see that they'll flash.

In MTA, you'll see that they aren't flashing normally, but if you drive under water, and move camera, you'll see flashing. This applies to both, squad cars + motorcycles, and predators.

ChrML

2005-09-14 18:55

administrator   ~~0000572

I haven't tested this myself yet, but my guess would be some of slush' DirectX rendering states aren't being resetted.

JonChappell

2005-09-14 21:47

manager   ~~0000573

I thought sirens weren't synced anyway.

jhxp

2005-09-19 13:36

administrator   ~~0000635

Last edited: 2005-09-19 13:37

Ok, important addition:

This applies to EVERY vehicle, which has flashing objects (excluding flashlights): for example, try flying rc baron in sp, and then in mtablue. You'll see that in sp, it flashes red and green, but in mta it doesn't. It does though, when you're underwater (drown).

I suggest changing the report's name.

jhxp

2005-10-03 22:50

administrator   ~~0000757

still there (read the note above)

slush

2005-11-03 07:11

administrator   ~~0001148

this one is odd as the rendering engine should be back to normal immediately after we're done drawing. I may be missing something here.

slush

2005-11-28 06:38

administrator   ~~0001742

Fixed; problem dealing with render states. [verified in map creator]

jhxp

2005-12-15 20:24

administrator   ~~0001859

still there :/

BlueZircon

2005-12-16 00:43

viewer   ~~0001863

Last edited: 2005-12-16 00:46

In pre-b16?

jhxp

2005-12-16 00:58

administrator   ~~0001866

yes, in b15 also (i think)

BlueZircon

2005-12-16 01:12

viewer   ~~0001867

Well, he said it was fixed in b16, so it's still going to happen in b15.

jhxp

2007-08-15 06:12

administrator   ~~0005351

Still there, still annoying :P

Jax

2007-08-15 10:57

administrator   ~~0005355

I guess this with a few other graphics glitches have returned with using the old text drawing methods

jhxp

2007-12-09 07:42

administrator   ~~0006661

Seems to be fixed in summoned-200712091254.

Talidan

2010-02-02 02:09

administrator   ~~0011032

Still happens with certain weather effects.

qaisjp

2016-02-21 20:28

administrator   ~~0024428

I tested all weather effects between 0-215. Lights seem to be working.

For certain weather effects at certain times of the day you can't see anything at all (including lights) so I think that's OK.

arranTuna

2018-02-21 00:17

manager   ~~0026442

Unknown what version this was fixed in so I'll just put 1.5

Issue History

Date Modified Username Field Change