View Issue Details

IDProjectCategoryView StatusLast Update
0001640Multi Theft Auto : San AndreasGeneralpublic2010-02-02 01:36
Reportererorr404Assigned To 
PriorityimmediateSeveritymajorReproducibilitysometimes
Status resolvedResolutionfixed 
Product Versionblue_sa.r2.a12 
Target Version1.0.4Fixed in Version1.0 
Summary0001640: Player animation desync
Description

Slothman killed me with a knife attack from behind and after I respawned I didn't see running/walking anims from him. He was sliding around in standing anim. We could hurt eachother and I saw attack/shoot anims from him. After a few respawns it got back to normal.

There is another version of this bug where the sliding player does not show shooting animations and therefore cannot hurt you.

TagsNo tags attached.

Relationships

related to 0001342 closederorr404 Remote player stuck in standing animation unable to do damage 
parent of 0002385 closed player gliding reproduced 
related to 0002035 resolvedeAi Players in first person view mode slide remotely 
related to 0002049 resolvedJax Jetpack desynced 
related to 0002355 closed Swimming animation not synced if you get out of a vehicle in water 
child of 0001672 closed Issues to be fixed ASAP! 

Activities

BrophY

2006-10-28 20:45

updater   ~~0003607

Last edited: 2006-10-28 20:45

this seems to happen quiet alot without any input

erorr404

2006-12-03 16:16

developer   ~~0003691

Last edited: 2006-12-03 16:18

Pretty major issue actually, it's ugly having such a desync.

Could it be from minimizing?

IJs

2007-01-20 17:32

administrator   ~~0003914

Still there I suppose?

erorr404

2007-01-20 19:03

developer   ~~0003955

Yes, I'm sure it is.

jhxp

2007-02-13 06:59

administrator   ~~0004049

Still a common issue

erorr404

2007-03-13 03:49

developer   ~~0004165

Closely related to 1342, only here you can hurt the effected person.

jbeta

2007-03-25 17:36

updater   ~~0004228

Got this with Slothman today (build 0325). Changing skin, or exiting and entering a vehicle, didn't work.

IJs

2007-04-25 20:42

administrator   ~~0004423

Need a way to reproduce.

jhxp

2007-04-28 05:17

administrator   ~~0004437

occurred in the mass test as well

erorr404

2007-05-06 21:43

developer   ~~0004533

This can be caused by minimizing. It just happened to me and the player would not show shooting anims (so he couldn't hurt me), but he could hit me with a bat.

erorr404

2007-05-13 06:48

developer   ~~0004552

Last edited: 2007-05-13 06:49

Just happened while I was playing with norby. I was shooting him with a sawn-off shotgun, then he fell into the water, and was sliding after he got out (when he fell in, there may have been a short desync - issue 2044). He couldn't shoot me because he was stuck in the standing animation on my screen. His swimming anim was fine though, and so was his bat hitting anim.

DracoBlue

2007-06-01 01:10

reporter   ~~0004675

"Reproducing" isn't possible, there is some kind of "random component".

We noticed while using running weapons (like Tec9, swan off) and real fast fight (with jumping/ducking) it often happens with these weapons (maybe because you walk and shoot at the same time?).

"Solveable" it was (on scripting side) by killing a slidding player and respawn it - what shouldn't be the soloution :-).

Is there anyway, we can see the "animation" state values or some kind of this? I am pretty sure, that there are gta_sa.exe-addresses (on the player-whos-animations-are-sliding) which don't get updated, when this bug appears.

erorr404

2007-07-08 07:31

developer   ~~0004969

Happened to me again with JackC. This time I didn't minimize or anything. He couldn't shoot me because I didn't see firing anims.

jbeta

2007-07-31 08:04

updater   ~~0005246

Apparently Slothman has found a way to reproduce it, see child report #2385 (I'll try it myself in a while).

erorr404

2007-07-31 17:06

developer   ~~0005249

This became much more frequent a few builds ago, so there's likely a new issue causing this. It could be related to the changes made to foot sync.

Jax

2007-08-14 16:55

administrator   ~~0005349

Calling SetPosition on remote players every frame probably made it more frequent

Iggy

2007-08-23 15:02

reporter   ~~0005433

Happened today in CTF.
video -
http://bastage.student.utwente.nl/mta-media/invincible___maybe.avi

jbeta

2007-09-05 10:59

updater   ~~0005611

The resource "taskinfo" will report all local and remote tasks for any player. If anyone spots a player with the sliding bug, please do /task nickname and paste the output here (/task with no arguments will list local tasks).

jbeta

2007-09-05 11:02

updater   ~~0005612

Last edited: 2007-09-05 12:32

jhxp just got it. The local and remote tasks don't match.

jhxp's tasks [locally for jbeta]:
Primary tasks:

  • TASK_PRIORITY_DEFAULT[1]: TASK_SIMPLE_PLAYER_ON_FOOT
    Secondary tasks:
  • TASK_SECONDARY_DUCK[1]: TASK_SIMPLE_DUCK
  • TASK_SECONDARY_FACIAL_COMPLEX[1]: TASK_COMPLEX_FACIAL

jhxp's tasks [locally for jhxp]:
Primary tasks:

  • TASK_PRIORITY_DEFAULT[1]: TASK_SIMPLE_PLAYER_ON_FOOT
    Secondary tasks:
  • TASK_SECONDARY_FACIAL_COMPLEX[1]: TASK_COMPLEX_FACIAL

jbeta

2007-09-05 11:23

updater   ~~0005613

Last edited: 2007-09-05 12:33

norby89 got it, with a different anim now. We still haven't managed to reproduce.

norby89's tasks [locally for jbeta]:
Primary tasks:

  • TASK_PRIORITY_DEFAULT[1]: TASK_SIMPLE_PLAYER_ON_FOOT
    Secondary tasks:
  • TASK_SECONDARY_DUCK[1]: TASK_SIMPLE_DUCK
  • TASK_SECONDARY_FACIAL_COMPLEX[1]: TASK_COMPLEX_FACIAL
  • TASK_SECONDARY_IK[1]: TASK_SIMPLE_IK_MANAGER

norby89's tasks [locally for norby89]:
Primary tasks:

  • TASK_PRIORITY_DEFAULT[1]: TASK_SIMPLE_PLAYER_ON_FOOT
    Secondary tasks:
  • TASK_SECONDARY_DUCK[1]: TASK_SIMPLE_DUCK
  • TASK_SECONDARY_FACIAL_COMPLEX[1]: TASK_COMPLEX_FACIAL

TASK_SIMPLE_IK_MANAGER is stuck on other clients, while norby89 doesn't have that task. Once he started sliding, crouching and uncrouching would remove the duck task in norby89's client, but not for remote clients.

EDIT: Streaming out of norby89's area and going back near him would clear the stuck task.

jbeta

2007-09-05 11:52

updater   ~~0005614

Last edited: 2007-09-05 12:34

Tried a process that seems to reproduce it frequently.

A player must crouch and get close to another one. When the crouched player attacks without uncrouching first, the other one blocks his attacks. After the player finishes punching, he will start sliding (task dumps obtained this way are identical to the one in ~5612).

When we tried the same a few more times without blocking the attacks, we ended up with the player not sliding (crouching worked, walking anims showed), but unable to punch remotely. The task dump was:

norby89's tasks [locally for jbeta]:
Primary tasks:

  • TASK_PRIORITY_DEFAULT[1]: TASK_SIMPLE_PLAYER_ON_FOOT
    Secondary tasks:
  • TASK_SECONDARY_FACIAL_COMPLEX[1]: TASK_COMPLEX_FACIAL
  • TASK_SECONDARY_IK[1]: TASK_SIMPLE_IK_MANAGER

norby89's tasks [locally for norby89]:
Primary tasks:

  • TASK_PRIORITY_DEFAULT[1]: TASK_SIMPLE_PLAYER_ON_FOOT
    Secondary tasks:
  • TASK_SECONDARY_ATTACK[1]: TASK_SIMPLE_FIGHT
  • TASK_SECONDARY_FACIAL_COMPLEX[1]: TASK_COMPLEX_FACIAL

jhxp

2007-09-05 12:11

administrator   ~~0005615

So generally there are two kinds of sliding.

One caused by what jbeta described - it's semi-permanent, and second, which is caused by some of the not-synced player animations - only for a brief moment, when such animation occurs. So I think this issue should be split into two different ones.

jbeta

2007-09-05 12:15

updater   ~~0005616

Last edited: 2007-09-05 12:34

Yet another one.

jhxp's tasks [locally for jbeta]:
Primary tasks:

  • TASK_PRIORITY_EVENT_RESPONSE_TEMP[1]: TASK_COMPLEX_IN_AIR_AND_LAND
  • TASK_PRIORITY_DEFAULT[1]: TASK_SIMPLE_PLAYER_ON_FOOT
    Secondary tasks:
  • TASK_SECONDARY_FACIAL_COMPLEX[1]: TASK_COMPLEX_FACIAL

jhxp's tasks [locally for jhxp]:
Primary tasks:

  • TASK_PRIORITY_DEFAULT[1]: TASK_SIMPLE_PLAYER_ON_FOOT
    Secondary tasks:
  • TASK_SECONDARY_FACIAL_COMPLEX[1]: TASK_COMPLEX_FACIAL

Locally to my client, there is an extra landing task, probably from when he spawned, since setskin makes you spawn underground and you fall down the map before getting warped to land.

Jax

2007-09-06 07:59

administrator   ~~0005627

Added a possible fix, needs testing again, log subtasks if it happens

norby89

2007-09-06 08:24

updater   ~~0005629

we got another one:

jbeta's tasks [locally for norby89]:
Primary tasks:

  • TASK_DEFAULT[0]: TASK_SIMPLE_PLAYER_ON_FOOT
    Secondary tasks:
  • TASK_SECONDARY_FACIAL_COMPLEX[0]: TASK_COMPLEX_FACIAL
  • TASK_SECONDARY_IK[0]: TASK_SIMPLE_IK_MANAGER
    jbeta's tasks [locally for jbeta]:
    Primary tasks:
  • TASK_DEFAULT[0]: TASK_SIMPLE_PLAYER_ON_FOOT
    Secondary tasks:
  • TASK_SECONDARY_ATTACK[0]: TASK_SIMPLE_FIGHT
  • TASK_SECONDARY_FACIAL_COMPLEX[0]: TASK_COMPLEX_FACIAL

Jax

2007-09-07 05:44

administrator   ~~0005643

Added another fix, this could go very right or verrrry wrong!

jbeta

2007-09-07 06:57

updater   ~~0005645

Well, ~5629 is not the sliding bug. It's another task-related bug where others couldn't see me punching, since TASK_SIMPLE_FIGHT wasn't the active task on their end.

As far as I know, we haven't been able to reproduce sliding since the first fix was put in.

Iggy

2007-09-08 22:06

reporter   ~~0005657

Not fixed, at the mass test today apparently I was sliding for norby, lasted quite awhile but then went away, and he waited to long before trying to get the tasks so he doesn't have that.

slothman

2007-09-09 04:56

updater   ~~0005659

i also saw him sliding at the same time, so it seems to be somewhat consistant for everyone when a particular person is sliding

jbeta

2007-09-09 06:59

updater   ~~0005660

It isn't, any other players who stream in the affected player after he starts sliding won't see the problem.

Jax

2007-09-14 04:57

administrator   ~~0005708

Add a note here if you get this, so we can track frequency/existance

jhxp

2007-09-22 06:53

administrator   ~~0005778

Should be fixed mostly. Only occasional sliding happened recently, and that can't be considered a 'block'.

Solide

2007-09-25 14:10

reporter   ~~0005812

Steps to reproduce: set your skin whilist you're being stabbed with a knife before you die. Not sure about other animations.

jbeta

2007-09-25 14:11

updater   ~~0005813

Task dump for the previous note:

So'lide's tasks [locally for jbeta]:
Primary tasks:

  • TASK_PHYSICAL_RESPONSE[0]: TASK_SIMPLE_STEALTH_KILL
  • TASK_DEFAULT[0]: TASK_SIMPLE_PLAYER_ON_FOOT
    Secondary tasks:
  • TASK_SECONDARY_FACIAL_COMPLEX[0]: TASK_COMPLEX_FACIAL

So'lide's tasks [locally for So'lide]:
Primary tasks:

  • TASK_DEFAULT[0]: TASK_SIMPLE_PLAYER_ON_FOOT
    Secondary tasks:
  • TASK_SECONDARY_FACIAL_COMPLEX[0]: TASK_COMPLEX_FACIAL

sinnerg

2007-10-01 19:10

reporter   ~~0005884

Happened alot on tfc_ctf-canals when I tested it with Lucif3r !

jhxp

2007-11-02 08:30

administrator   ~~0006120

still there?

ChrML

2007-11-20 18:55

administrator   ~~0006406

Does this happen a lot these days? I did add something a few nightlies ago that could limit the occurances of this.

Arc

2007-12-07 12:52

administrator   ~~0006640

Dragon was sliding on assault today. His tasks were the same on his machine as on mine though:

Primary task: none
Physical response task: none
Event rsp tmp task: none
Event rsp nontmp task: none
Default task name: TASK_SIMPLE_PLAYER_ON_FOOT
Default task type: 0
Secondary attack task task: none
Secondary duck task task: none
Secondary say task task: none
Secondary facial task name: TASK_COMPLEX_FACIAL
Secondary facial task type: 305
Secondary partial anim task task: none
Secondary IK task task: none

jbeta

2007-12-16 10:40

updater   ~~0006783

Found a player sliding ingame (Mxxd), I did a dump but didn't get the tasks on his client on time. Attached to report.

AlienX

2007-12-16 10:50

viewer   ~~0006784

No idea if this has anything to do with it... but every little helps eh?

These here:
In water: 0
On ground: 0
Is climbing: 0

on both dumps all say false, but they had to be on the ground??? - might be totally wrong, but its worth telling you.

jbeta

2007-12-16 11:06

updater   ~~0006786

MeKorea now.

ChrML

2007-12-16 11:11

administrator   ~~0006788

Last edited: 2007-12-16 11:12

Lets try to get a few more dumps where you know the sliding player is not jumping and that there are more streamed in players around that are not jumping. Lets compare the reports and see if the On ground bool can indicate some connection here :). Maybe we're on to something. I can't imagine GTA would do all the animations on a player it doesn't think is on the ground even.

ChrML

2007-12-18 05:47

administrator   ~~0006817

This dreaded issue is finally fixed. :) Ty lil_today for reproducing it.

ChrML

2007-12-18 05:47

administrator   ~~0006818

This dreaded issue is finally fixed. :) Ty lil_today for reproducing it.

Arc

2007-12-21 12:53

administrator   ~~0006834

Player sliding is not fixed completely. We did a short test today and it still appeared multiple times.

ChrML

2007-12-21 18:02

administrator   ~~0006838

You guys must figure out exactly what is causing this this time. As last time, it's probably some task that requires removal before respawning the player, so something the player is doing at the time of setPlayerSkin or respawn is causing it.

jbeta

2007-12-26 18:15

updater   ~~0006882

Dump from 26-12 beta test:
http://clanlr.net/kongui/dump_21154125.txt

Jax

2007-12-29 13:21

administrator   ~~0006920

Hopefully this is gone now, re-open if it pops up again.

Arc

2007-12-30 16:35

administrator   ~~0006943

.

:P

ChrML

2008-01-03 21:29

administrator   ~~0006993

Should be completely fixed now with all possible causes eliminated.

erorr404

2008-01-10 01:08

developer   ~~0007078

It still happens Developer Preview 2, seems most often in deathmatch modes like CDM.

ChrML

2008-01-10 09:57

administrator   ~~0007081

Find out why it happens this time. We've eliminated two causes already which was related to players changing skins/respawning when not dead on certain events, like jumping and climbing fences. Now the players are recreated totally when changing skins/respawning when not dead, so this issue can no longer happen with those.

So apparently there are more things causing this, please find out what.

Ransom

2008-02-28 16:23

administrator   ~~0007338

One thing i was wondering, when i get hit by an explosion and killed or something and do a setSkin command in fr to spawn i go to where i was before blown up and tossed away, could that cause issues of not following where the player goes after getting blown up?

ChrML

2008-03-02 11:39

administrator   ~~0007379

Bump

Ransom

2008-03-03 20:13

administrator   ~~0007401

I'm not sure if this is directly related to not being able to shoot sometimes. MeKorea found a way to reproduce sliding/control sticking by doing setskin while the player is in the 'bent knees' animation after jumping.

I didn't intend to make this bug so urgent because of visual desync, but rather the severe weapon desync that can (or can occur) separately of it. We were not able to reproduce shooting issues this way as you can see on public servers like FMJ or simbad.

Jax

2008-03-18 05:37

administrator   ~~0007510

http://forum.mtasa.com/viewtopic.php?f=95&t=21496

erorr404

2008-03-19 15:47

developer   ~~0007511

So to sum up Phat Looser's observations, the bug is with the observer of the floating player, and it seems to go away after the observer dies or respawns. What's interesting is that he says it persists after the observer reconnects or restarts the game.

Arc

2008-03-21 02:15

administrator   ~~0007514

What's interesting is that he says it persists after the observer reconnects or restarts the game.
The way I read it it's the other way around: the observer still sees the slider floating after the slider reconnects.

Ransom

2008-05-28 04:00

administrator   ~~0007793

bump... what to say about this report nowadays

jhxp

2008-12-01 12:42

administrator   ~~0008214

To be verified on 1.0 .

BigBadButler

2009-03-22 07:27

viewer   ~~0008594

I just looked through the MTA code for half an hour and I got the impression that you use the "PlayerActor" structure to sync the "PlayerPed".
Since you have to increase the count of this structure from 8 to "player count", could it be that this desync bug is a GTA internal bug?
Because when I tried to find the "floating" players, it seemed that the "PlayerPed" pointer the "PlayerActor" struct had was zero.

That would explain why streaming out and streaming in the player fixes the bug.
On the other hand, I'm pretty sure you already thought of that.

Talidan

2010-02-02 01:36

administrator   ~~0011019

Not seen this for a while. Closing until further information is collected.

Issue History

Date Modified Username Field Change