View Issue Details

IDProjectCategoryView StatusLast Update
0001254Multi Theft Auto : San AndreasGeneralpublic2007-09-16 21:49
ReporterRansomAssigned ToeAi 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionduplicate 
Product Versionblue_sa.r2.a12 
Target VersionFixed in Version 
Summary0001254: Abnormalities in created objects
Description

So far we have noticed the following abnormalities:

  1. They are icy when you sprint on them

  2. Cannot hang from them, either you autoclimb (which is usually done when you are climbing small objects) or it is too high for CJ

  3. Many created objects put underwater or partially underwater appear not to have any water covering them

TagsNo tags attached.

Relationships

related to 0001257 resolvedeAi Cannot jump down after grasping an object 
related to 0001329 closedryden Player can "see through" created objects outside the game area 
parent of 0001968 closed CJ falls down sometimes when running into placed objects 
parent of 0001969 resolved Large objects can spin very fast or show huge stretched triangle textures 
parent of 0002003 resolvedIJs maps objects not loading 
parent of 0002448 closedryden Added objects aren't recognized as ground pieces 
parent of 0002517 resolvedryden Created objects are slippery when walking on them 
parent of 0002518 resolvedIJs Created objects put underwater or partially underwater appear not to have any water covering them 
parent of 0002502 closed Many animated objects frozen stiff now 
related to 0001271 resolvedccw Object limit increase 

Activities

BlueZircon

2006-04-22 12:48

viewer   ~~0002955

This really needs to be fixed.

Ransom

2006-04-25 02:40

administrator   ~~0002973

I concur.

erorr404

2006-04-25 02:48

developer   ~~0002974

Also you stay in place when they are moving, rather than moving with them. The side opposite from the direction of motion also becomes collision-less.

jhxp

2006-04-25 10:13

administrator   ~~0002976

true

ChrML

2006-05-17 11:26

administrator   ~~0003065

This will fix itself if we get buildings to work.

Ransom

2006-09-20 23:05

administrator   ~~0003503

bumped - urgent

slothman

2006-09-21 01:27

updater   ~~0003504

i can drop down from normal objects

jhxp

2007-04-06 07:44

administrator   ~~0004307

Any progress on it?

Ransom

2007-04-25 22:03

administrator   ~~0004425

The streaming is pretty bad on these objects as well. Go to the desert and you'll see everything really far away easily. Play c&c_weapons and you can't see the entire thing, even though its small. Created objects have lots of problems...

IJs

2007-04-25 22:07

administrator   ~~0004426

How big are the objects you're using Ransom, and how many are you using. That's probably the cause of your specific problems.

Also, that note is not relevant to this bug.

Ransom

2007-04-26 14:10

administrator   ~~0004430

I'm well aware of the limits, as I showed with port 69, these are much less, it just cant stream big objects well. 250 vs. 450 is a huge difference

So how is this not related? It obviously is a result of applying objects in an inappropriate way, or else they would work properly. It is related and worth noting. The streamer has been changed many times, with no avail.

IJs

2007-08-25 09:59

administrator   ~~0005454

Regarding the under-water issue: it could very well be that GTA has no checks to set an object as "under water" (under water objects require a different way of rendering, as you may have noticed). This would mean either we, or you, have to implement this. I don't think it's really important right now.

jbeta

2007-09-16 21:45

updater   ~~0005742

Splitting this bug on dev request.

Issue History

Date Modified Username Field Change